summaryrefslogtreecommitdiff
path: root/src/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/CMakeLists.txt')
-rw-r--r--src/test/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/test/CMakeLists.txt b/src/test/CMakeLists.txt
index db478dcc..5f394617 100644
--- a/src/test/CMakeLists.txt
+++ b/src/test/CMakeLists.txt
@@ -8,7 +8,7 @@ include_directories(
)
if(ICU_FOUND)
- include_directories(${ICU_INCLUDE_DIR})
+ include_directories(${ICU_INCLUDE_DIRS})
endif()
if(BDB_FOUND)
@@ -66,10 +66,7 @@ macro(buildme _name _srcs)
target_link_libraries(${_name} ${CMAKE_THREAD_LIBS_INIT})
if(ICU_FOUND)
- target_link_libraries(${_name} ${ICU_LIBRARY})
- endif()
- if(ICU_I18N_FOUND)
- target_link_libraries(${_name} ${ICU_I18N_LIBRARY})
+ target_link_libraries(${_name} ${ICU_LIBRARIES})
endif()
if(BDB_FOUND)
target_link_libraries(${_name} ${BDB_LIBRARY})