summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..5bfcc8a
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,28 @@
+# libhangul
+# Copyright (C) 2018 Choe Hwanjin
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+.DELETE_ON_ERROR:
+
+doc: Doxyfile hangulkeyboards.dox
+ doxygen Doxyfile
+
+hangulkeyboards.dox: gen_hangulkeyboards.py ../hangul/hangulkeyboard.h
+ $(srcdir)/gen_hangulkeyboards.py $(top_srcdir)/hangul/hangulkeyboard.h > $@
+
+clean-local:
+ -rm -f hangulkeyboards.dox
+ -rm -rf html