summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..4352a81
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,16 @@
+include $(top_srcdir)/Makefile.decl
+
+all-local: check-local
+
+if HAVE_UMOCKDEV
+
+noinst_PROGRAMS = test-enumerator-filter
+TEST_PROGS += $(noinst_PROGRAMS)
+
+test_enumerator_filter_SOURCES = test-enumerator-filter.c
+test_enumerator_filter_CFLAGS = $(UMOCKDEV_CFLAGS) -I$(top_srcdir)
+test_enumerator_filter_LDADD = $(UMOCKDEV_LIBS) $(top_builddir)/libgudev-1.0.la
+
+endif
+
+EXTRA_DIST = test-enumerator-filter.c