summaryrefslogtreecommitdiff
path: root/libgphoto2_port/usb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgphoto2_port/usb/Makefile.am')
-rw-r--r--libgphoto2_port/usb/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/libgphoto2_port/usb/Makefile.am b/libgphoto2_port/usb/Makefile.am
index 5b115aba7..ced574bd3 100644
--- a/libgphoto2_port/usb/Makefile.am
+++ b/libgphoto2_port/usb/Makefile.am
@@ -6,12 +6,13 @@ usb_la_LDFLAGS = -module -no-undefined -avoid-version \
-export-dynamic \
-export-symbols $(top_srcdir)/iolib.sym
usb_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(CPPFLAGS) \
$(INTL_CFLAGS) \
- $(AM_CPPFLAGS) $(LIBUSB_CFLAGS) \
- $(CPPFLAGS)
+ $(LIBUSB_CFLAGS)
usb_la_DEPENDENCIES = $(top_srcdir)/iolib.sym
usb_la_LIBADD = \
+ $(top_builddir)/libgphoto2_port/libgphoto2_port.la \
$(LIBUSB_LIBS) \
- $(INTLLIBS) \
- $(top_builddir)/libgphoto2_port/libgphoto2_port.la
+ $(INTLLIBS)
usb_la_SOURCES = libusb.c