summaryrefslogtreecommitdiff
path: root/camlibs/spca50x/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camlibs/spca50x/Makefile.am')
-rw-r--r--camlibs/spca50x/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/camlibs/spca50x/Makefile.am b/camlibs/spca50x/Makefile.am
new file mode 100644
index 000000000..d1793697b
--- /dev/null
+++ b/camlibs/spca50x/Makefile.am
@@ -0,0 +1,16 @@
+camlib_LTLIBRARIES = spca50x.la
+
+EXTRA_DIST = ChangeLog.benq ChangeLog.gsmart ChangeLog.spca504_flash lsusb-v README.spca50x
+
+spca50x_la_SOURCES = spca50x.c spca50x.h \
+ spca50x-flash.c spca50x-flash.h \
+ spca50x-sdram.c spca50x-sdram.h \
+ library.c \
+ spca50x-jpeg-header.h spca50x-registers.h \
+ spca50x-avi-header.h
+spca50x_la_LDFLAGS = -module -no-undefined -avoid-version -export-dynamic \
+ -export-symbols $(top_srcdir)/camlibs/camlib.sym
+spca50x_la_DEPENDENCIES = $(top_srcdir)/camlibs/camlib.sym
+spca50x_la_LIBADD = $(top_builddir)/libgphoto2/libgphoto2.la
+
+camlibdoc_DATA = README.spca50x