summaryrefslogtreecommitdiff
path: root/camlibs/gsmart300/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camlibs/gsmart300/Makefile.am')
-rw-r--r--camlibs/gsmart300/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/camlibs/gsmart300/Makefile.am b/camlibs/gsmart300/Makefile.am
new file mode 100644
index 000000000..fc336c8d1
--- /dev/null
+++ b/camlibs/gsmart300/Makefile.am
@@ -0,0 +1,11 @@
+camlib_LTLIBRARIES = gsmart300.la
+
+gsmart300_la_SOURCES = gsmart300.c gsmart300.h library.c \
+ gsmart300-jpeg-header.h
+gsmart300_la_LDFLAGS = -module -no-undefined -avoid-version -export-dynamic \
+ -export-symbols $(top_srcdir)/camlibs/camlib.sym
+gsmart300_la_DEPENDENCIES = $(top_srcdir)/camlibs/camlib.sym
+gsmart300_la_LIBADD = $(top_builddir)/libgphoto2/libgphoto2.la
+
+camlibdoc_DATA = README.gsmart300
+EXTRA_DIST = README.gsmart300