summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2006-10-14 11:54:47 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2006-10-14 11:54:47 +0000
commitfd692a071e71409e43ae10828c59f48034564e1c (patch)
treec7a4f6abfd6f1e33fdd0d3ea4318e245aa34c6a9 /Makefile.am
parent77b5ff66241cf0edd021ff97b5bc0ae9113cf5db (diff)
downloadlibgphoto2-fd692a071e71409e43ae10828c59f48034564e1c.tar.gz
Move header files one last time to reduce file path lengths in tarball.
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@9330 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 33 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 9be3a9f42..ae3e0fe31 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,11 +12,21 @@ SUBDIRS = @subdirs@ libgphoto2 camlibs tests po bindings packaging doc
doc_DATA = AUTHORS COPYING README NEWS
-# Remove obsolete directory of copied/symlinked header files
-all-local:
- if test -d gphoto2; then rm -f gphoto2/gphoto2*.h; rmdir gphoto2; fi
-clean-local:
- if test -d gphoto2; then rm -f gphoto2/gphoto2*.h; rmdir gphoto2; fi
+nobase_include_HEADERS = \
+ gphoto2/gphoto2.h \
+ gphoto2/gphoto2-abilities-list.h\
+ gphoto2/gphoto2-camera.h \
+ gphoto2/gphoto2-context.h \
+ gphoto2/gphoto2-file.h \
+ gphoto2/gphoto2-filesys.h \
+ gphoto2/gphoto2-library.h \
+ gphoto2/gphoto2-list.h \
+ gphoto2/gphoto2-result.h \
+ gphoto2/gphoto2-setting.h \
+ gphoto2/gphoto2-version.h \
+ gphoto2/gphoto2-widget.h
+
+DISTCLEANFILES = libgphoto2/gphoto2-endian.h
# we use just ONE .PHONY target in order not to confuse automake
@@ -69,3 +79,21 @@ endif
# released version
cvs-tags: Makefile
@echo cvs tag "@PACKAGE@-$$(echo '@VERSION@' | sed -e 's/\./_/g' -e 's/rc/-rc/g')"
+
+
+
+# Compatibility for header inclusions.
+#
+# - Old code has -I/usr/include/gphoto2
+# #include <gphoto2-camera.h>
+#
+# - New code has -I/usr/include
+# #include <gphoto2/gphoto2-camera.h>
+
+install-data-local:
+ rm -f $(DESTDIR)$(includedir)/gphoto2/gphoto2
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(includedir)/gphoto2
+ $(LN_S) . $(DESTDIR)$(includedir)/gphoto2/gphoto2
+
+uninstall-local:
+ rm -f $(DESTDIR)$(includedir)/gphoto2/gphoto2