summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 88d616cec..a00ab600a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -87,6 +87,11 @@ check_prototype_definition_safe(qsort_s
check_function_exists(getentropy GIT_RAND_GETENTROPY)
check_function_exists(getloadavg GIT_RAND_GETLOADAVG)
+# poll
+
+check_symbol_exists(poll poll.h GIT_IO_POLL)
+check_symbol_exists(select sys/select.h GIT_IO_SELECT)
+
# determine architecture of the machine
if(CMAKE_SIZEOF_VOID_P EQUAL 8)