summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSascha Cunz <Sascha@BabbelBox.org>2012-12-18 19:07:59 +0100
committerSascha Cunz <Sascha@BabbelBox.org>2012-12-19 04:57:12 +0100
commitc5309eb2da80f04e3ad445c340d18fbe5babbc6a (patch)
tree46fdc88dde71def8134118483b4ef6b23e5c07b0 /CMakeLists.txt
parent49b630086e16545b0770a3425adcfdcc83863599 (diff)
downloadlibgit2-c5309eb2da80f04e3ad445c340d18fbe5babbc6a.tar.gz
Remove special case source globs for Solaris
With the src/compat/*.c glob removed, there is no longer a difference to the default globs we use for the IF( UNIX ) case.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3bec692f3..64e5da44e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -150,8 +150,6 @@ FILE(GLOB SRC_H include/git2/*.h)
IF (WIN32 AND NOT CYGWIN)
ADD_DEFINITIONS(-DWIN32 -D_DEBUG -D_WIN32_WINNT=0x0501)
FILE(GLOB SRC src/*.c src/transports/*.c src/xdiff/*.c src/win32/*.c)
-ELSEIF (CMAKE_SYSTEM_NAME MATCHES "(Solaris|SunOS)")
- FILE(GLOB SRC src/*.c src/transports/*.c src/xdiff/*.c src/unix/*.c)
ELSEIF (AMIGA)
ADD_DEFINITIONS(-DNO_ADDRINFO -DNO_READDIR_R)
FILE(GLOB SRC src/*.c src/transports/*.c src/xdiff/*.c src/amiga/*.c)