summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2013-01-23 17:38:00 -0600
committerEdward Thomson <ethomson@edwardthomson.com>2013-01-23 17:38:00 -0600
commitc27e211219574324ef9eaf7980b04e5e08189169 (patch)
treeeefc9714fbc603383a438458a3c280905ae81444 /CMakeLists.txt
parent0d52cb4aea2e0af1b8a4a8557e26c9edf85c96db (diff)
downloadlibgit2-c27e211219574324ef9eaf7980b04e5e08189169.tar.gz
update examples to work on windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47533a282..e9972fd41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -288,7 +288,11 @@ ENDIF ()
IF (BUILD_EXAMPLES)
FILE(GLOB_RECURSE EXAMPLE_SRC examples/network/*.c)
ADD_EXECUTABLE(cgit2 ${EXAMPLE_SRC})
- TARGET_LINK_LIBRARIES(cgit2 git2 pthread)
+ IF(WIN32)
+ TARGET_LINK_LIBRARIES(cgit2 git2)
+ ELSE()
+ TARGET_LINK_LIBRARIES(cgit2 git2 pthread)
+ ENDIF()
ADD_EXECUTABLE(git-diff examples/diff.c)
TARGET_LINK_LIBRARIES(git-diff git2)