summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Martín Nieto <cmn@dwim.me>2013-08-11 01:37:44 +0200
committerCarlos Martín Nieto <cmn@dwim.me>2013-08-14 10:49:10 +0200
commit5be622fb563c89341a7dd5da4e65e2c225cb2c08 (patch)
treeda2ffe696873010b093c643e8f914ebd6d6c62fa /CMakeLists.txt
parent2af9bcb2dbb47adafa7eecbf41ff113da7fa9d1b (diff)
downloadlibgit2-5be622fb563c89341a7dd5da4e65e2c225cb2c08.tar.gz
Test SSH in travis
Set up the ssh credentials so we are able to talk to localhost and issue git commands. Move to use a script, as the command list is getting somewhat long. While here, delay installing valgrind until we need it, as it and its dependencies are by far the largest downloads and this allows us to start compiling (and failing) faster and we only incur this cost when the test suite runs successfully.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1500a3a68..1c70ec2d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,7 +148,9 @@ ELSE()
FILE(GLOB SRC_ZLIB deps/zlib/*.c deps/zlib/*.h)
ENDIF()
-FIND_PACKAGE(LIBSSH2 QUIET)
+IF (NOT MINGW)
+ FIND_PACKAGE(LIBSSH2 QUIET)
+ENDIF()
IF (LIBSSH2_FOUND)
ADD_DEFINITIONS(-DGIT_SSH)
INCLUDE_DIRECTORIES(${LIBSSH2_INCLUDE_DIR})