summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index bc05b07f..5f743eb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,19 +78,16 @@ AC_SUBST(GDK_PIXBUF_LIBS)
PKG_CHECK_MODULES([GTK], [gtk+-3.0 >= $GTK_REQS], [have_gtk=yes], [have_gtk=no])
AM_CONDITIONAL([HAVE_GTK], [test "x$have_gtk" = "xyes"])
-# GNOME support, which pulls in libsoup-gnome-2.4 to provide transparent proxy support
+# GNOME support, which pulls in libsoup-gnome-2.4 to provide transparent proxy support and gnome-keyring-1 to provide non-pageable memory
AC_MSG_CHECKING(whether to build with GNOME support)
AC_ARG_ENABLE(gnome, AS_HELP_STRING([--enable-gnome], [Whether to enable GNOME support]),, enable_gnome=yes)
AC_MSG_RESULT($enable_gnome)
if test "x$enable_gnome" = "xyes"; then
AC_DEFINE(HAVE_GNOME, 1, [Defined if GNOME support is enabled])
- PKG_CHECK_MODULES(GNOME, [libsoup-gnome-2.4])
+ PKG_CHECK_MODULES([GNOME], [libsoup-gnome-2.4 gnome-keyring-1])
fi
-AC_SUBST(GNOME_CFLAGS)
-AC_SUBST(GNOME_LIBS)
-
# Various necessary functions and headers
AC_CHECK_FUNCS([strchr])
AC_CHECK_FUNCS([strstr])