summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2013-09-04 09:04:30 -0600
committerPhilip Withnall <philip@tecnocode.co.uk>2013-09-27 16:27:48 -0600
commitfcc2d13dc25eba59d8fb52daaa9ede4e5604e0f2 (patch)
treeaf5030ebf8e4af27d54c25af8c975ecfbf594df0 /configure.ac
parent8fa173f7d34aa2094df28140cd3508a307de9fc0 (diff)
downloadlibgdata-fcc2d13dc25eba59d8fb52daaa9ede4e5604e0f2.tar.gz
build: Add extra compiler warnings to the build
This is dependent on recent changes in gnome-common (bug #707475). The new compiler warnings can be disabled by setting --enable-compile-warnings to anything other than ‘yes’ or ‘maximum’ during configuration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 28 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d070c58..252d6e03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,7 +141,34 @@ GNOME_CODE_COVERAGE
# General GNOME macros
GNOME_DEBUG_CHECK
-GNOME_COMPILE_WARNINGS([maximum])
+GNOME_COMPILE_WARNINGS([maximum],[
+ -Wdeclaration-after-statement
+ -Wextra
+ -Winline
+ -Wpacked
+ -Wlarger-than-65500
+ -Wmissing-declarations
+ -Wmissing-format-attribute
+ -Wmissing-noreturn
+ -Wold-style-definition
+ -Wsign-compare
+ -Wstrict-aliasing=2
+ -Wswitch-enum
+ -Wundef
+ -Wunsafe-loop-optimizations
+ -Wwrite-strings
+ -Wno-missing-field-initializers
+ -Wno-unused-parameter
+ -Wshadow
+ -Wcast-align
+ -Wformat-nonliteral
+ -Wswitch-default
+ -Waggregate-return
+ -Wredundant-decls
+ -Wunused-but-set-variable
+ -Warray-bounds
+])
+
GNOME_MAINTAINER_MODE_DEFINES
GOBJECT_INTROSPECTION_CHECK([0.9.7])