summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2014-08-09 16:39:10 +0100
committerPhilip Withnall <philip@tecnocode.co.uk>2014-08-09 16:39:10 +0100
commitae6134187af336a878d460817441a58b0a9b2365 (patch)
tree1f9c2ad88b9bf3d27a4f59fdf2c3976bbc0f60cd /configure.ac
parente16460a3992fc6cb2f44c3b7ff25cdc2ab4c10a9 (diff)
downloadlibgdata-ae6134187af336a878d460817441a58b0a9b2365.tar.gz
build: Add missing configure checks spotted by autoscan
Thanks, autoscan!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d0ad8a3..20dac767 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,9 +147,15 @@ dnl ****************************
PKG_CHECK_MODULES(UHTTPMOCK, libuhttpmock-0.0)
# Various necessary functions and headers
+AC_CHECK_FUNCS([memset])
+AC_CHECK_FUNCS([setlocale])
AC_CHECK_FUNCS([strchr])
AC_CHECK_FUNCS([strstr])
AC_CHECK_HEADERS([sys/time.h])
+AC_CHECK_HEADERS([arpa/inet.h])
+AC_CHECK_HEADERS([locale.h])
+AC_CHECK_HEADERS([netinet/in.h])
+AC_CHECK_HEADERS([sys/socket.h])
# Internationalisation support
GETTEXT_PACKAGE=gdata