summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2012-07-16 21:08:00 +0100
committerPhilip Withnall <philip@tecnocode.co.uk>2012-07-16 21:11:32 +0100
commit56a39743779f63791e27886aaa3a9338602406f3 (patch)
tree9a07e7e8886fa7fff07fa34a682a4e0515dd2afe /configure.ac
parente483d930c86ba20d390051713f34bc9ed1da0289 (diff)
downloadlibgdata-56a39743779f63791e27886aaa3a9338602406f3.tar.gz
Bug 656976 — Merge eds and GNOME Documents GOA authorisers
Copy the GOA authoriser from EDS into libgdata, modifying it a bit to add support for non-Contacts services and remove use of the liboauth HMAC function in favour of GLib’s implementation. This is essentially the same code as used by GNOME Documents. Originally written by Matthew Barnes. He’s given permission for it to be relicenced from LGPL v2 or v3 to LGPL v2.1+. (See the bug report.) This adds the following API: • GDataGoaAuthorizer This is currently untested; waiting to port EDS and GNOME Documents to it to test it. Closes: https://bugzilla.gnome.org/show_bug.cgi?id=656976
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ae9547d6..2e4adf07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,7 @@ GIO_REQS=2.17.3
SOUP_REQS=2.37.91
OAUTH_REQS=0.9.4
GTK_REQS=2.91.2
+GOA_REQS=3.2
# Before making a release, the GDATA_LT_VERSION string should be modified. The string is of the form c:r:a. Follow these instructions sequentially:
#
@@ -61,8 +62,10 @@ AC_SUBST(GDATA_API_VERSION)
AC_SUBST(GDATA_API_VERSION_MAJOR)
AC_SUBST(GDATA_API_VERSION_MINOR)
-pkg_modules="glib-2.0 >= $GLIB_REQS libxml-2.0 gthread-2.0 gio-2.0 >= $GIO_REQS libsoup-2.4 >= $SOUP_REQS oauth >= $OAUTH_REQS"
-PKG_CHECK_MODULES(GDATA, [$pkg_modules])
+GDATA_PACKAGES="glib-2.0 >= $GLIB_REQS libxml-2.0 gthread-2.0 gio-2.0 >= $GIO_REQS libsoup-2.4 >= $SOUP_REQS oauth >= $OAUTH_REQS"
+AC_SUBST([GDATA_PACKAGES])
+
+PKG_CHECK_MODULES(GDATA, [$GDATA_PACKAGES])
AC_SUBST(GDATA_CFLAGS)
AC_SUBST(GDATA_LIBS)
@@ -82,10 +85,14 @@ AM_CONDITIONAL([HAVE_GTK], [test "x$have_gtk" = "xyes"])
AC_MSG_CHECKING(whether to build with GNOME support)
AC_ARG_ENABLE(gnome, AS_HELP_STRING([--enable-gnome], [Whether to enable GNOME support]),, enable_gnome=yes)
AC_MSG_RESULT($enable_gnome)
+AM_CONDITIONAL([ENABLE_GNOME], [test "x$enable_gnome" = "xyes"])
+
+GNOME_PACKAGES="libsoup-gnome-2.4 gnome-keyring-1 goa-1.0 >= $GOA_REQS"
+AC_SUBST([GNOME_PACKAGES])
if test "x$enable_gnome" = "xyes"; then
AC_DEFINE(HAVE_GNOME, 1, [Defined if GNOME support is enabled])
- PKG_CHECK_MODULES([GNOME], [libsoup-gnome-2.4 gnome-keyring-1])
+ PKG_CHECK_MODULES([GNOME], [$GNOME_PACKAGES])
fi
# Various necessary functions and headers