summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2015-07-05 12:49:44 +0100
committerPhilip Withnall <philip@tecnocode.co.uk>2015-07-05 14:09:56 +0100
commit718513ef649b7af7d15e76432eef72180012c08b (patch)
treeb7045a8797f8caf6e89f4ae0aaf555fb92de2a2e /configure.ac
parentb53780890f548b8fbbc4cf30d1aafd1b61cc4b8d (diff)
downloadlibgdata-718513ef649b7af7d15e76432eef72180012c08b.tar.gz
tests: Fix query parameter comparisons involving dates in YouTube tests
The only way to implement some of the standard feeds in the YouTube service is now to query filtering against the current date, which means that a custom message comparison function has to be installed into the uhttpmock code to ignore that query parameter when replacing HTTP traces. Use some new convenience API in libuhttpmock to achieve this. Dependency changes: • libuhttpmock ≥ 0.5.0 https://bugzilla.gnome.org/show_bug.cgi?id=750914
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d376c756..c20d1d83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,7 +169,7 @@ AC_SUBST([ENABLE_INSTALLED_TESTS],[$enable_installed_tests])
AS_IF([test "$enable_always_build_tests" = "yes" ||
test "$enable_installed_tests" = "yes"],[
- PKG_CHECK_MODULES([UHTTPMOCK],[libuhttpmock-0.0])
+ PKG_CHECK_MODULES([UHTTPMOCK],[libuhttpmock-0.0 >= 0.5.0])
])
# Various necessary functions and headers