summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2014-03-17 02:05:17 +0100
committerCarlos Garnacho <carlosg@gnome.org>2014-05-27 02:36:27 +0200
commit7d919fd88d88fa39f6870588826469bdae811d1a (patch)
treef8216771d112d5150a69906135cb2f832c61c966 /Makefile.am
parentb03f422a2e87dda27f593c866a45c1f112b4f6a8 (diff)
downloadlibgdata-7d919fd88d88fa39f6870588826469bdae811d1a.tar.gz
Add Freebase service
This service is, according to the main site, a "A community-curated database of well-known people, places, and things", it allows searching for and offering information about a wide range of topics, in a well-structured and uniform manner. The most low-level API is the MQL query interface, that is a JSON-based language, queries consist of a data graph (according to their data schema) with blank places, that will be filled in in the reply. https://bugzilla.gnome.org/show_bug.cgi?id=726486
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 028f0f71..e255abcc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -305,6 +305,13 @@ gdatatasksinclude_HEADERS = \
gdata/services/tasks/gdata-tasks-task.h \
gdata/services/tasks/gdata-tasks-query.h
+gdatafreebaseincludedir = $(gdataincludedir)/services/freebase
+gdata_freebase_headers = \
+ gdata/services/freebase/gdata-freebase-service.h \
+ gdata/services/freebase/gdata-freebase-result.h \
+ gdata/services/freebase/gdata-freebase-query.h
+gdatafreebaseinclude_HEADERS = \
+ $(gdata_freebase_headers)
gdata_sources = \
gdata/gdata-entry.c \
@@ -413,7 +420,12 @@ gdata_sources = \
gdata/services/tasks/gdata-tasks-service.c \
gdata/services/tasks/gdata-tasks-tasklist.c \
gdata/services/tasks/gdata-tasks-task.c \
- gdata/services/tasks/gdata-tasks-query.c
+ gdata/services/tasks/gdata-tasks-query.c \
+ \
+ gdata/services/freebase/gdata-freebase-service.c \
+ gdata/services/freebase/gdata-freebase-result.c \
+ gdata/services/freebase/gdata-freebase-query.c
+
if ENABLE_GOA
gdata_sources += \
@@ -434,7 +446,8 @@ public_headers = \
$(gdatadocumentsinclude_HEADERS) \
$(gdatapicasawebinclude_HEADERS) \
$(gdatayoutubeinclude_HEADERS) \
- $(gdatatasksinclude_HEADERS)
+ $(gdatatasksinclude_HEADERS) \
+ $(gdatafreebaseinclude_HEADERS)
gdata_libgdata_la_SOURCES = \
$(GDATA_MARSHAL_FILES) \
@@ -450,10 +463,12 @@ gdata_libgdata_la_CPPFLAGS = \
-I$(top_srcdir)/gdata/services/documents \
-I$(top_srcdir)/gdata/services/picasaweb \
-I$(top_srcdir)/gdata/services/youtube \
+ -I$(top_srcdir)/gdata/services/freebase \
-I$(top_builddir)/gdata \
-I$(top_builddir)/gdata/media \
-I$(top_builddir)/gdata/services/picasaweb \
-I$(top_builddir)/gdata/services/youtube \
+ -I$(top_builddir)/gdata/services/freebase \
-DG_LOG_DOMAIN=\"libgdata\" \
$(DISABLE_DEPRECATED) \
$(AM_CPPFLAGS)