summaryrefslogtreecommitdiff
path: root/expat.spec
diff options
context:
space:
mode:
authorfdrake <fdrake>2001-03-01 04:43:23 +0000
committerfdrake <fdrake>2001-03-01 04:43:23 +0000
commit92fb5c5b60fd7ef52a1399ba3677ba4e3a21cb74 (patch)
tree2e23588ba1df2b23ad97cfaea3c9e22dd4514dcd /expat.spec
parent33a5c1b1851f02c84b11d77cbfd5f73443057d23 (diff)
downloadlibexpat-92fb5c5b60fd7ef52a1399ba3677ba4e3a21cb74.tar.gz
Added .spec file for building RPMs; contributed by Sean Reifschneider.
Minor changes to reflect build process updates and bump the version number for the next release; remove the "tummy" suffix from the RPM version since this is part of the stock package.
Diffstat (limited to 'expat.spec')
-rw-r--r--expat.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/expat.spec b/expat.spec
new file mode 100644
index 0000000..4d5f1e6
--- /dev/null
+++ b/expat.spec
@@ -0,0 +1,55 @@
+%define version 1.95.2
+%define release 1
+
+Summary: Expat is an XML 1.0 parser written in C.
+Name: expat
+Version: %{version}
+Release: %{release}
+Copyright: Mozilla or GPL
+Group: Utilities/parsers
+URL: http://expat.sourceforge.net/
+Source: http://download.sourceforge.net/expat/expat-%{version}.tar.gz
+BuildRoot: /var/tmp/%{name}-buildroot
+
+%description
+Expat is an XML 1.0 parser written in C by James Clark. It aims to be
+fully conforming. It is currently not a validating XML parser.
+
+%prep
+%setup
+
+%build
+./configure
+make lib xmlwf
+
+%install
+
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT/bin
+mkdir -p $RPM_BUILD_ROOT/usr/lib
+mkdir -p $RPM_BUILD_ROOT/usr/include
+make install prefix=$RPM_BUILD_ROOT/usr
+install -D xmlwf/xmlwf $RPM_BUILD_ROOT/usr/bin/xmlwf
+
+%files
+%doc COPYING Changes MANIFEST README doc/reference.html doc/style.css
+/usr/bin/xmlwf
+/usr/lib
+/usr/include
+
+%changelog
+* Sun Feb 18 2001 Sean Reifschneider <jafo-rpms@tummy.com>
+[Release 1.95.1-1tummy]
+- Updated to 1.95.1 release.
+- Removed the "/usr/include/expat" directory for headers, as it now uses
+ "expat.h" instead of "xmlparser.h".
+
+* Thu Jan 25 2001 Sean Reifschneider <jafo-rpms@tummy.com>
+[Release 1.1-3tummy]
+- Moved xmlparse.h into "/usr/include/expat" directory to prevent conflict
+ with w3c-libwww-devel package.
+
+* Wed Sep 6 2000 Sean Reifschneider <jafo-rpms@tummy.com>
+- Modified to install into /usr.
+- Modified to use RPM_BUILD_ROOT instead of writing directly to install
+ location.