summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfdrake <fdrake>2003-10-16 04:32:39 +0000
committerfdrake <fdrake>2003-10-16 04:32:39 +0000
commiteb097a865a6548850aa960dccffa2f8134868fe5 (patch)
tree67627d4cc06de58322adb9f3a9f1e941b1f80399 /configure.in
parent6c9ab179622c603cfcd26936f48e662148b02a50 (diff)
downloadlibexpat-eb097a865a6548850aa960dccffa2f8134868fe5.tar.gz
- reorganize by the components that need what we're checking for
- remove the check for memcmp(); we didn't use the result of the check (though we do use memcmp())
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 721c265..035cd42 100644
--- a/configure.in
+++ b/configure.in
@@ -80,7 +80,6 @@ fi
dnl Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h unistd.h)
dnl Checks for typedefs, structures, and compiler characteristics.
@@ -89,12 +88,12 @@ dnl work in a cross compile.
AC_C_BIGENDIAN_CROSS
AC_C_CONST
-AC_TYPE_OFF_T
AC_TYPE_SIZE_T
+AC_CHECK_FUNCS(memmove bcopy)
-dnl Checks for library functions.
-
-AC_FUNC_MEMCMP
+dnl Only needed for xmlwf:
+AC_CHECK_HEADERS(fcntl.h unistd.h)
+AC_TYPE_OFF_T
AC_FUNC_MMAP
if test "$ac_cv_func_mmap_fixed_mapped" = "yes"; then
@@ -104,10 +103,10 @@ else
fi
AC_SUBST(FILEMAP)
-AC_CHECK_FUNCS(memmove bcopy)
+dnl Only needed for regression tests:
AC_CHECK_HEADERS(check.h)
-dnl some basic configuration
+dnl Some basic configuration:
AC_DEFINE([XML_NS], 1,
[Define to make XML Namespaces functionality available.])
AC_DEFINE([XML_DTD], 1,