summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorgstein <gstein>2002-05-17 21:30:06 +0000
committergstein <gstein>2002-05-17 21:30:06 +0000
commit845f541776a1f00846fcfb2a100d685c09711914 (patch)
tree984c2e6dd77c1c2c9b8df03effd4b8a05eaa5d4f /configure.in
parentdb1344ca72a1ac2926c39aeeaafa06bf9a753516 (diff)
downloadlibexpat-845f541776a1f00846fcfb2a100d685c09711914.tar.gz
Various configuration fixes, focused primarily around expat_config.h
(which used to be called config.h) * configure.in: - change the header name to expat_config.h to prevent any possible conflict with some other packages 'config.h' - add a prerequisite on autoconf 2.50 or newer - shift some acconfig.h values to AC_DEFINE() values * MANIFEST: - rename config.h.in to expat_config.h.in * Makefile.in: - clean out expat_config.h* instead of config.h* * acconfig.h: - remove the XML_NS, XML_DTD, and XML_CONTEXT_BYTES symbols; they are now defined directly by configure.in - shift the memmove() compatibility to xmlparse.c, its only consumer - remove the @BOTTOM@ part since there are no more values to put at the bottom of expat_config.h.in via acconfig.h * xmlparse.c: - switch from config.h to expat_config.h - insert macro to define memmove() if it isn't available, but bcopy() is available. also, changed one branch to #error rather than insert bogus code. * xmlrole.c: - tweak the copyright header, per Fred-ism - remove the unused RCSId[] variable (no other file has these) - switch from config.h to expat_config.h * xmltok.c: - switch from config.h to expat_config.h
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 12ab407..1cd9e7a 100644
--- a/configure.in
+++ b/configure.in
@@ -10,6 +10,9 @@ dnl under the terms of the License (based on the MIT/X license) contained
dnl in the file COPYING that comes with this distribution.
dnl
+dnl Ensure that subversion is configured with autoconf 2.50 or newer
+AC_PREREQ(2.50)
+
AC_INIT(Makefile.in)
AC_CONFIG_AUX_DIR(conftools)
@@ -29,7 +32,7 @@ LIBCURRENT=1
LIBREVISION=0
LIBAGE=1
-AC_CONFIG_HEADER(config.h)
+AC_CONFIG_HEADER(expat_config.h)
sinclude(conftools/libtool.m4)
sinclude(conftools/ac_c_bigendian_cross.m4)
@@ -87,6 +90,14 @@ AC_SUBST(FILEMAP)
AC_CHECK_FUNCS(memmove bcopy)
+dnl some basic configuration
+AC_DEFINE([XML_NS], 1,
+ [Define to make XML Namespaces functionality available.])
+AC_DEFINE([XML_DTD], 1,
+ [Define to make parameter entity parsing functionality available.])
+AC_DEFINE([XML_CONTEXT_BYTES], 1024,
+ [Define to specify how much context to retain around the current parse point.])
+
AC_OUTPUT(Makefile)
abs_srcdir="`cd $srcdir && pwd`"