summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorgstein <gstein>2001-03-10 15:41:49 +0000
committergstein <gstein>2001-03-10 15:41:49 +0000
commit825b2ef8ee20dd3bc8afc42f8a71d0bf3ff9331c (patch)
tree456f683cb1653b38351b94d342a1d7ea7db497a9 /configure.in
parentfa1583d55f63038980a0ea95af12edba94faa1be (diff)
downloadlibexpat-825b2ef8ee20dd3bc8afc42f8a71d0bf3ff9331c.tar.gz
Revamp config/build to keep generated files out of CVS (some libtool files
were out of date, and we've previously seen expat.h out of sync). *) Use new script "buildconf.sh" to create the set of generated files (aclocal.m4, config.h.in, configure). This is intended to be used by developers (rerun when configure.in changes) and just before a release (releases include these outputs). Developers now need the "autoconf" and "libtool" packages. *) config.h.in is now built by autoheader and includes bits from acconfig.h rather than manual construction/maintenance. (renamed from config.hin) *) added conftools/PrintPath from the ASF; it is a portable "which" *) added "extraclean" target to top-level Makefile to get rid of all generated files (return to pure CVS state; before buildconf.sh) *) updates various bits for config.hin -> config.h.in rename *) no longer need to delete the ".deps" subdir since we don't create it anymore (dependencies are explicit rather than auto-generated).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b0e299f..f59ec45 100644
--- a/configure.in
+++ b/configure.in
@@ -43,7 +43,7 @@ LIBCURRENT=1
LIBREVISION=0
LIBAGE=1
-AC_CONFIG_HEADER(config.h:config.hin)
+AC_CONFIG_HEADER(config.h)
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
@@ -78,12 +78,13 @@ dnl Checks for library functions.
AC_FUNC_MEMCMP
AC_FUNC_MMAP
-AC_SUBST(FILEMAP_OBJ)
+
if test -z "$HAVE_MMAP"; then
FILEMAP_OBJ=unixfilemap.o
else
FILEMAP_OBJ=readfilemap.o
fi
+AC_SUBST(FILEMAP_OBJ)
AC_CHECK_FUNCS(memmove bcopy)