summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a69650f6..9904bdb1 100644
--- a/configure.in
+++ b/configure.in
@@ -35,11 +35,16 @@ esac
dnl Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
-AC_PROG_SED
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MKDIR_P
+# AC_PROG_SED is only available in Autoconf >= 2.59b; workaround for older
+# versions
+ifdef([AC_PROG_SED], [AC_PROG_SED], [
+AC_CHECK_PROGS(SED, [gsed sed])
+])
+
AC_PROG_GCC_TRADITIONAL
# We need to test for at least gcc 2.95 here, because older versions don't