summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fffb339..0cce0769 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -135,10 +135,11 @@ if SIGNAL_SUPPORT
SYS_SRC += signal.c
endif
-BUILT_SOURCES = event-config.h
+BUILT_SOURCES = ./include/event2/event-config.h
-event-config.h: config.h
- echo '/* event-config.h' > $@
+./include/event2/event-config.h: config.h
+ @MKDIR_P@ ./include/event2
+ echo '/* event2/event-config.h' > $@
echo ' *' >> $@
echo ' * This file was generated by autoconf when libevent was built, and post-' >> $@
echo ' * processed by Libevent so that its macros would have a uniform prefix.' >> $@
@@ -147,8 +148,8 @@ event-config.h: config.h
echo ' *' >> $@
echo ' * Do not rely on macros in this file existing in later versions.'>> $@
echo ' */' >> $@
- echo '#ifndef _EVENT_CONFIG_H_' >> $@
- echo '#define _EVENT_CONFIG_H_' >> $@
+ echo '#ifndef _EVENT2_EVENT_CONFIG_H_' >> $@
+ echo '#define _EVENT2_EVENT_CONFIG_H_' >> $@
sed -e 's/#define /#define _EVENT_/' \
-e 's/#undef /#undef _EVENT_/' \
@@ -201,15 +202,13 @@ noinst_HEADERS = util-internal.h mm-internal.h ipv6-internal.h \
minheap-internal.h log-internal.h evsignal-internal.h evmap-internal.h \
changelist-internal.h iocp-internal.h \
ratelim-internal.h \
- WIN32-Code/event-config.h \
+ WIN32-Code/event2/event-config.h \
WIN32-Code/tree.h \
compat/sys/queue.h
include_HEADERS = event.h evhttp.h evdns.h evrpc.h evutil.h
-nodist_include_HEADERS = event-config.h
-
-INCLUDES = -I$(srcdir)/compat -I$(srcdir)/include $(SYS_INCLUDES)
+INCLUDES = -I$(srcdir)/compat -I$(srcdir)/include -I./include $(SYS_INCLUDES)
verify: check
@@ -217,4 +216,5 @@ doxygen: FORCE
doxygen $(srcdir)/Doxyfile
FORCE:
-DISTCLEANFILES = *~ event-config.h libevent.pc
+DISTCLEANFILES = *~ libevent.pc ./include/event2/event-config.h
+