summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-04-18 00:12:52 +0000
committerNick Mathewson <nickm@torproject.org>2009-04-18 00:12:52 +0000
commite4f24219ee93f3b9dc20991b18e71230468b7b94 (patch)
tree7a3ece8a94e2578c4e5ff3248dc25f275743c535 /test/Makefile.am
parenta98a512bc1dc85a87cd00fa7682aeccaeea2859c (diff)
downloadlibevent-e4f24219ee93f3b9dc20991b18e71230468b7b94.tar.gz
Add a new bench_httpclient for a trivial codecon demo.
svn:r1198
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 55ff2e4d..1e1e0423 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -5,7 +5,7 @@ AM_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/compat -I$(top_srcdir)/include
EXTRA_DIST = regress.rpc regress.gen.h regress.gen.c
noinst_PROGRAMS = test-init test-eof test-weof test-time regress \
- bench bench_cascade bench_http
+ bench bench_cascade bench_http bench_httpclient
noinst_HEADERS = tinytest.h tinytest_macros.h regress.h
BUILT_SOURCES = regress.gen.c regress.gen.h
@@ -41,6 +41,8 @@ bench_cascade_SOURCES = bench_cascade.c
bench_cascade_LDADD = ../libevent.la
bench_http_SOURCES = bench_http.c
bench_http_LDADD = ../libevent.la
+bench_httpclient_SOURCES = bench_httpclient.c
+bench_httpclient_LDADD = ../libevent_core.la
regress.gen.c regress.gen.h: regress.rpc $(top_srcdir)/event_rpcgen.py
$(top_srcdir)/event_rpcgen.py $(srcdir)/regress.rpc || echo "No Python installed"