summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTay Ray Chuan <raychuan@iweb.nus.edu.sg>2013-01-15 12:52:08 +0800
committerTay Ray Chuan <raychuan@iweb.nus.edu.sg>2013-01-16 00:47:02 +0800
commit9ab2b3f7496c05091ad2ac31ede2e8e806b85e38 (patch)
treeeb769407cab97aacbed2f18f3833414657577b2a /configure.in
parentca80ea61b5f0cf0e3f2e1cef756e7405e22d310b (diff)
downloadlibevent-9ab2b3f7496c05091ad2ac31ede2e8e806b85e38.tar.gz
Fix missing AC_PROG_SED on older Autoconfs
For pre-2.59b Autoconfs, AC_PROG_SED is not available [1]; on such systems, avoid calling AC_PROG_SED, while providing a sensible SED. This aids backporting to Autoconf 2.59. [1] http://lists.gnu.org/archive/html/autotools-announce/2004-08/msg00002.html
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a69650f6..9904bdb1 100644
--- a/configure.in
+++ b/configure.in
@@ -35,11 +35,16 @@ esac
dnl Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
-AC_PROG_SED
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MKDIR_P
+# AC_PROG_SED is only available in Autoconf >= 2.59b; workaround for older
+# versions
+ifdef([AC_PROG_SED], [AC_PROG_SED], [
+AC_CHECK_PROGS(SED, [gsed sed])
+])
+
AC_PROG_GCC_TRADITIONAL
# We need to test for at least gcc 2.95 here, because older versions don't