summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2014-03-03 11:23:55 -0500
committerNick Mathewson <nickm@torproject.org>2014-03-03 11:23:55 -0500
commitcbfa8da1793251ae32c882d0ef289217219a3b11 (patch)
treef1ef659e616cf756c6adab54937f5687cb94b3fc /configure.ac
parent3908a5e3d0ebc310f1f258c5e8994cf71d3b011a (diff)
parentb56611d705a2c77eacb1a8da7ee0ee360e0c75bc (diff)
downloadlibevent-cbfa8da1793251ae32c882d0ef289217219a3b11.tar.gz
Merge remote-tracking branch 'origin/patches-2.0'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a2a47bfa..2073b4ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -816,6 +816,15 @@ if test x$enable_gcc_warnings != xno && test "$GCC" = "yes"; then
# Disable the unused-function warnings, because these trigger
# for minheap-internal.h related code.
CFLAGS="$CFLAGS -Wno-unused-function"
+
+ # clang on macosx emits warnigns for each directory specified which
+ # isn't "used" generating a lot of build noise (typically 3 warnings
+ # per file
+ case "$host_os" in
+ darwin*)
+ CFLAGS="$CFLAGS -Qunused-arguments"
+ ;;
+ esac
fi
##This will break the world on some 64-bit architectures