summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKevin Greenan <kmgreen2@gmail.com>2014-07-16 08:39:36 -0700
committerKevin Greenan <kmgreen2@gmail.com>2014-07-16 08:43:47 -0700
commit0be44ad3ca61604a719edc1257ca9dfc258bdc0b (patch)
tree46e34a2ebe90cb923d708f1f356b27096ac8c020 /src/Makefile.am
parentc41559c125c9f5445221e39bf57439411443f2e4 (diff)
downloadliberasurecode-0be44ad3ca61604a719edc1257ca9dfc258bdc0b.tar.gz
Remove required gf-complete dependency from liberasurecode.
NOTE: We need to ensure that any erasure code backend using algebraic signatures *must use* the same exact GF as those used in this library. This usually means same 'w' and primitive polynomial. I plan to make the same change to Jerasure, so it will be compatible.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5751f5f..fb2368d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,7 +16,11 @@ liberasurecode_la_SOURCES = \
liberasurecode_la_CPPFLAGS = -Werror
liberasurecode_la_LIBADD = \
- builtin/xor_codes/libXorcode.la -lgf_complete -lpthread
+ builtin/xor_codes/libXorcode.la -lpthread
+
+if GF_COMPLETE_INSTALLED
+ liberasurecode_la_LIBADD += -lgf_complete
+endif
# Version format (C - A).(A).(R) for C:R:A input
liberasurecode_la_LDFLAGS = -rpath '$(libdir)' -version-info 9:10:9