summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-01-18 14:24:09 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-01-25 12:28:29 +0000
commit6b68ddeaa04d2eebae79a148738bfe619c58f088 (patch)
treeb370841774f60462ac09b4337f0fc816e79d327d /configure.ac
parent2aec628eb015b85ab08650289277de2af2b2efc4 (diff)
downloadlibepoxy-6b68ddeaa04d2eebae79a148738bfe619c58f088.tar.gz
build: Skip GLESv1 tests if there's no GLESv1
It's pretty much pointless to build and run tests for a library that we know is not available. The Meson build already skips the GLES 1.0 test, so let's make the Autotools build do the same.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d67726..e733267 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,6 +119,9 @@ fi
AM_CONDITIONAL(HAS_ZNOW, test x$has_znow = xyes)
+AC_CHECK_LIB([GLESv1_CM], [glFlush], [has_gles1=yes], [has_gles1=no])
+AM_CONDITIONAL(HAS_GLES1, test x$has_gles1 = xyes)
+
AC_CHECK_LIB([dl], [dlopen], [DLOPEN_LIBS="-ldl"])
AC_SUBST([DLOPEN_LIBS])