summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82d27b6..eaf5171 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,13 @@ fi
AC_SUBST([BSYMBOLIC_LDFLAG])
+##############################################
+# Check whether MSVC toolset is explicitly set
+##############################################
+
+AM_CONDITIONAL(MSVC_BASE_NO_TOOLSET_SET, [test x$MSVC_BASE_TOOLSET = x])
+AM_CONDITIONAL(MSVC_NO_TOOLSET_SET, [test x$MSVC_TOOLSET = x])
+
###################
# Compiler warnings
###################
@@ -155,6 +162,7 @@ build/win32/vs10/croco-version-paths.props
build/win32/vs11/Makefile
build/win32/vs12/Makefile
build/win32/vs14/Makefile
+build/win32/vs15/Makefile
docs/Makefile
docs/examples/Makefile
docs/reference/Makefile