summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c9044a4..7712a89 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,14 +25,19 @@ EXTRA_DIST = motd ce-createpipe.c
BUILT_SOURCES =
CLEANFILES =
-testtools = socks5
-
-TESTS = version pipeconnect
+TESTS = version
if HAVE_W32CE_SYSTEM
w32cetools = ce-createpipe ce-server
endif
+if HAVE_W32_SYSTEM
+testtools =
+else
+TESTS += pipeconnect
+testtools = socks5
+endif
+
if USE_DESCRIPTOR_PASSING
TESTS += fdpassing
endif