summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 812f407d9..01136029c 100644
--- a/configure.in
+++ b/configure.in
@@ -79,7 +79,18 @@ dnl
dnl prep libtool
dnl
echo "performing libtool configuration..."
-AC_PROG_LIBTOOL
+
+case "$host_alias" in
+*os2*)
+ # Use a custom made libtool replacement
+ echo "using aplibtool"
+ LIBTOOL="$srcdir/build/aplibtool"
+ gcc -o $LIBTOOL.exe $LIBTOOL.c
+ ;;
+*)
+ AC_PROG_LIBTOOL
+ ;;
+esac
dnl #----------------------------- Checks for compiler flags
nl='