summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 7b3ab3552..178005ac7 100644
--- a/configure.in
+++ b/configure.in
@@ -4,6 +4,8 @@ dnl
dnl Process this file with autoconf to produce a configure script.
dnl Use ./buildconf to prepare build files and run autoconf for APR.
+AC_PREREQ(2.50)
+
AC_INIT(build/apr_common.m4)
AC_CONFIG_HEADER(include/arch/unix/apr_private.h)
AC_CONFIG_AUX_DIR(build)
@@ -1804,14 +1806,10 @@ AC_SUBST(osuuid)
dnl ----------------------------- Checking for Time Support
echo "${nl}Checking for Time Support..."
-AC_CACHE_CHECK([for tm_gmtoff in struct tm], ac_cv_struct_tm_gmtoff,
-[AC_TRY_COMPILE([#include <sys/types.h>
-#include <time.h>], [struct tm tm; tm.tm_gmtoff;],
- ac_cv_struct_tm_gmtoff=yes, ac_cv_struct_tm_gmtoff=no)])
-if test "$ac_cv_struct_tm_gmtoff" = "yes"; then
- AC_DEFINE(HAVE_GMTOFF, 1, [Define if struct tm has a tm_gmtoff field])
-fi
+AC_CHECK_MEMBERS([struct tm.tm_gmtoff, struct tm.__tm_gmtoff],,,[
+#include <sys/types.h>
+#include <time.h>])
dnl ----------------------------- Checking for Networking Support
echo "${nl}Checking for Networking support..."