summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfuankg <fuankg@13f79535-47bb-0310-9956-ffa450edef68>2011-03-29 15:49:27 +0000
committerfuankg <fuankg@13f79535-47bb-0310-9956-ffa450edef68>2011-03-29 15:49:27 +0000
commit69501dea5f14d88788f220d91c54dc4ee4d20d21 (patch)
treecd2bbfd107d99b550c30a51b87d9f32fc5186828 /configure.in
parent312c959e20a56d7510089919d20a7d704e7b5fbb (diff)
downloadlibapr-69501dea5f14d88788f220d91c54dc4ee4d20d21.tar.gz
Fixed apr_ino_t typedef for MinGW builds.
git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@1086633 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 17 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 30d6e851f..0db0f5ac5 100644
--- a/configure.in
+++ b/configure.in
@@ -1720,15 +1720,24 @@ AC_MSG_RESULT($off_t_value)
# releases did. To be correct, apr_ino_t should have been made an
# ino64_t as apr_off_t is off64_t, but this can't be done now without
# breaking ABI.
-ino_t_value=ino_t
-APR_CHECK_SIZEOF_EXTENDED(AC_INCLUDES_DEFAULT, ino_t, $ac_cv_sizeof_long)
-if test $ac_cv_sizeof_ino_t = 4; then
- if test $ac_cv_sizeof_long = 4; then
- ino_t_value="unsigned long"
- else
- ino_t_value="unsigned int"
+
+# Per OS tuning...
+case $host in
+*mingw*)
+ ino_t_value=apr_int64_t
+ ;;
+*)
+ ino_t_value=ino_t
+ APR_CHECK_SIZEOF_EXTENDED(AC_INCLUDES_DEFAULT, ino_t, $ac_cv_sizeof_long)
+ if test $ac_cv_sizeof_ino_t = 4; then
+ if test $ac_cv_sizeof_long = 4; then
+ ino_t_value="unsigned long"
+ else
+ ino_t_value="unsigned int"
+ fi
fi
-fi
+ ;;
+esac
AC_MSG_NOTICE([using $ino_t_value for ino_t])
# Checks for endianness