summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordreid <dreid@13f79535-47bb-0310-9956-ffa450edef68>2000-06-03 15:27:55 +0000
committerdreid <dreid@13f79535-47bb-0310-9956-ffa450edef68>2000-06-03 15:27:55 +0000
commitc7c34f8ad197eff3a8aaac64dc6839deea052600 (patch)
tree4cf2e175d990a9085d69571baf215a5cc7a87518 /configure.in
parente7a92631ad75ad15858e255f996956887ec3f5c5 (diff)
downloadlibapr-c7c34f8ad197eff3a8aaac64dc6839deea052600.tar.gz
BeOS doesn't have a native MMAp, but there the ap_mmap functions have
been written and work just fine. This allows us to tell APR that this is the case and have the APR_HAS_MMAP flag set accordingly. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@60138 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e5292e6f0..c9cfe7b64 100644
--- a/configure.in
+++ b/configure.in
@@ -94,6 +94,7 @@ case "$OS" in
CFLAGS="$CFLAGS -DBEOS"
enable_apr_threads="system_threads"
config_subdirs="shmem/unix/mm"
+ native_mmap_emul="1"
;;
*)
OSDIR="unix"
@@ -407,6 +408,8 @@ echo $ac_n "${nl}Checking for MMAP...${nl}"
AC_FUNC_MMAP
if test "$ac_cv_func_mmap_fixed_mapped" = "yes"; then
mmap="1"
+elif test "$native_mmap_emul" = "1"; then
+ mmap="1"
else
mmap="0"
fi