summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorrbb <rbb@13f79535-47bb-0310-9956-ffa450edef68>2000-06-01 01:01:16 +0000
committerrbb <rbb@13f79535-47bb-0310-9956-ffa450edef68>2000-06-01 01:01:16 +0000
commitaa2b9e1841aab6335673d80292423b1971149243 (patch)
treef1f17de04ca92795060b4165adbd69d4b48cc5fa /configure.in
parent4ae6295dae9e35054f9ff1745d6850d7612a3c71 (diff)
downloadlibapr-aa2b9e1841aab6335673d80292423b1971149243.tar.gz
Fix building with DSO support. If any module is configured to be
compiled for shared support then APR_HAS_DSO is enabled and -ldl is added to the LIBS variable. -ldl may need to be modified based on platform. If no modules are designated as shared then APR_HAS_DSO is disabled and nothing is added to LIBS. In basic testing this compiled without errors or warnings. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@60122 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3c5119343..58123a7bd 100644
--- a/configure.in
+++ b/configure.in
@@ -317,6 +317,22 @@ AC_SUBST(ssize_t_value)
AC_SUBST(ssize_t_fmt)
AC_SUBST(off_t_fmt)
+dnl #----------------------------- Checking for DSO support
+echo $ac_n "${nl}Checking for DSO...${nl}"
+AC_CACHE_CHECK([for DSO support], ac_cv_enable_dso,
+ [ AC_ARG_ENABLE(dso,
+ [ --enable-dso Enable reliable child processes ],
+ [ ac_cv_enable_dso=$enableval],
+ [ aprdso="1" ] ) ] )
+
+if test "$ac_cv_enable_dso" = "no"; then
+ aprdso="0"
+else
+ aprdso="1"
+fi
+
+AC_SUBST(aprdso)
+
dnl #----------------------------- Checking for Threads
echo $ac_n "${nl}Checking for Threads...${nl}"
AC_CACHE_CHECK([for threads], ac_cv_enable_threads,