summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2000-06-10 12:02:31 +0000
committertrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2000-06-10 12:02:31 +0000
commit5ecd8d91613d4c71615bfe2ebcb1c9ebbcd604b8 (patch)
tree2a64fa85dc28b5311a8a5a6370e2629bda2c4a4c /configure.in
parentab70e9ae17af21ed2236b8e88f6e92945c681d49 (diff)
downloadlibapr-5ecd8d91613d4c71615bfe2ebcb1c9ebbcd604b8.tar.gz
Get FreeBSD building again with the resource limiting changes (FreeBSD
3.4, at least). rlim_t is defined in <sys/types.h>, so we usually need that. Some stuff in <sys/resource.h> needs <sys/time.h> for timeval just to be able to compile :( git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@60161 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3d12c423d..bb447beec 100644
--- a/configure.in
+++ b/configure.in
@@ -424,7 +424,10 @@ AC_ARG_ENABLE(other-child,
AC_SUBST(oc)
AC_MSG_CHECKING(struct rlimit)
-AC_TRY_RUN([#include <sys/resource.h>
+AC_TRY_RUN([
+#include <sys/types.h>
+#include <sys/time.h>
+#include <sys/resource.h>
main()
{
struct rlimit limit;