summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2003-08-24 23:18:22 +0000
committerjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2003-08-24 23:18:22 +0000
commitdda565ef6a6afbb9741a2cabc2f4e17a200f7b7a (patch)
tree52e8612d0bd0b850562e0d07fdb46f9d0b06264e /configure.in
parentaa8bf90e40cad9fff7f3b9cfa0e57f7471739e8f (diff)
downloadlibapr-dda565ef6a6afbb9741a2cabc2f4e17a200f7b7a.tar.gz
Add an --experimental-libtool option that allows the user to specify an
alternate libtool. (jlibtool.c isn't included with APR, but this just allows support for it by dropping it into the tree in the 'right' place alongside aplibtool.c.) git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@64595 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 21 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 4955e2858..1b39a31a8 100644
--- a/configure.in
+++ b/configure.in
@@ -129,6 +129,9 @@ dnl prep libtool
dnl
echo "performing libtool configuration..."
+AC_ARG_ENABLE(experimental-libtool,[ --experimental-libtool Use experimental custom libtool (not included in source distribution)],
+ [experimental_libtool=$enableval],[experimental_libtool=no])
+
case $host in
*os2*)
# Use a custom-made libtool replacement
@@ -136,15 +139,27 @@ case $host in
LIBTOOL="$srcdir/build/aplibtool"
gcc $CFLAGS $CPPFLAGS -o $LIBTOOL.exe $LIBTOOL.c
;;
-*) dnl libtoolize requires that the following not be indented
-AC_PROG_LIBTOOL
+*)
if test "x$LTFLAGS" = "x"; then
LTFLAGS='--silent'
fi
- # get libtool's setting of shlibpath_var
- eval `grep "^shlibpath_var=[[A-Z_]]*$" $apr_builddir/libtool`
- if test "x$shlibpath_var" = "x"; then
- shlibpath_var=REPLACE_WITH_YOUR_SHLIBPATH_VAR
+ if test "$experimental_libtool" = "yes"; then
+ # Use a custom-made libtool replacement
+ echo "using jlibtool"
+ LIBTOOL="$apr_builddir/libtool"
+ LIBTOOL_SRC="$apr_srcdir/build/jlibtool.c"
+ if test ! -f $LIBTOOL_SRC; then
+ AC_MSG_ERROR([Experimental libtool source not found. It is not included with APR by default.])
+ fi
+ $CC $CFLAGS $CPPFLAGS -o $LIBTOOL $LIBTOOL_SRC
+ else
+ dnl libtoolize requires that the following not be indented
+AC_PROG_LIBTOOL
+ # get libtool's setting of shlibpath_var
+ eval `grep "^shlibpath_var=[[A-Z_]]*$" $apr_builddir/libtool`
+ if test "x$shlibpath_var" = "x"; then
+ shlibpath_var=REPLACE_WITH_YOUR_SHLIBPATH_VAR
+ fi
fi
;;
esac