summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2003-08-24 23:09:19 +0000
committerjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2003-08-24 23:09:19 +0000
commit409f68b5102ae57ef32b306e525bd14fc5e90125 (patch)
treef2d3563fb33cebe347fb53e534f3fa5db2e597d9 /configure.in
parente9765f06e30ec1e07efadf265bb801dde9afe624 (diff)
downloadlibapr-409f68b5102ae57ef32b306e525bd14fc5e90125.tar.gz
Re-enable IPv6 on Darwin 6.6 and beyond as it looks like getaddrinfo() now
works with IPv4-mapped addresses. (It works here, but independent confirmation would be welcomed.) git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@64593 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index e163a2810..4955e2858 100644
--- a/configure.in
+++ b/configure.in
@@ -435,7 +435,10 @@ case $host in
*linux*)
os_version=`uname -r | sed -e 's/\(.\)\.\(.\)\.\(.\).*/\1\2\3/'`
;;
- *)
+ *darwin*)
+ os_version=`uname -r | sed -e 's/\(.\)\.\(.\).*/\1\2/'`
+ ;;
+ *)
os_version=OS_VERSION_IS_NOT_SET
;;
esac
@@ -1781,9 +1784,14 @@ AC_ARG_ENABLE(ipv6,
case $host in
*apple-darwin*)
# It appears that Jaguar has all the right features, but
- # getnameinfo() fails to find the hostname for a mapped
+ # getnameinfo() fails to find the hostname for an IPv4mapped
# address.
- broken_ipv6=1
+ # All signs point that 6.6 (aka Mac OS 10.2.6+) is okay.
+ if test $os_version -lt "66"; then
+ broken_ipv6=1
+ else
+ broken_ipv6=0
+ fi
;;
*)
broken_ipv6=0