summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2002-11-05 16:01:51 +0000
committertrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2002-11-05 16:01:51 +0000
commitcecd008a589a63feb954655962d3e7ab2ce385b3 (patch)
tree9a3e708960a70ec3ddb18c9f69357c369751dd27 /configure.in
parent9efb7177bf45a46c4b81edff6d0da0698f353d24 (diff)
downloadlibapr-cecd008a589a63feb954655962d3e7ab2ce385b3.tar.gz
ReliantUnix: recognize that dlsym() is in libdl and dlopen() is in
libc. The check is generic so maybe this fixes some other system. PR: 14189 git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@63998 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 16ac20548..56bf5ca37 100644
--- a/configure.in
+++ b/configure.in
@@ -1283,6 +1283,17 @@ AC_ARG_ENABLE(dso,
AC_CHECK_LIB(dl, dlopen, [ tempdso="dlfcn" APR_ADDTO(LIBS,-ldl) ],
tempdso="no")
fi
+ if test "$tempdso" = "dlfcn"; then
+ # ReliantUnix has dlopen() in libc but dlsym() in libdl :(
+ AC_CHECK_FUNCS(dlsym, [ tempdso="dlfcn" ], [ tempdso="no" ])
+ if test "$tempdso" = "no"; then
+ AC_CHECK_LIB(dl, dlsym, [ tempdso="dlfcn" APR_ADDTO(LIBS, -ldl) ],
+ tempdso="no")
+ fi
+ if test "$tempdso" = "no"; then
+ echo "Weird: dlopen() was found but dlsym() was not found!"
+ fi
+ fi
if test "$tempdso" = "no"; then
AC_CHECK_LIB(root, load_image, tempdso="yes", tempdso="no")
fi