summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2002-09-10 09:11:20 +0000
committerjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2002-09-10 09:11:20 +0000
commitab99ddb3dddb97a6241dfa4ff0d7d7131b482b45 (patch)
tree4cc00a44a50049a875f3c52fef13f8b0b391c09e /configure.in
parent4dc00a6afd64bd26c538772f995b0378bbfbf669 (diff)
downloadlibapr-ab99ddb3dddb97a6241dfa4ff0d7d7131b482b45.tar.gz
Make it a little easier to drop get-version.sh into apr-util by removing
the hardcoded APR prefix to the version defines and taking that as a parameter. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@63855 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 7edba41a3..08b88bf41 100644
--- a/configure.in
+++ b/configure.in
@@ -69,8 +69,8 @@ APR_MKDIR_P_CHECK($apr_builders/mkdir.sh)
dnl get our version information
get_version="$apr_builders/get-version.sh"
version_hdr="$apr_srcdir/include/apr_version.h"
-APR_MAJOR_VERSION="`$get_version major $version_hdr`"
-APR_DOTTED_VERSION="`$get_version all $version_hdr`"
+APR_MAJOR_VERSION="`$get_version major $version_hdr APR`"
+APR_DOTTED_VERSION="`$get_version all $version_hdr APR`"
AC_SUBST(APR_DOTTED_VERSION)
AC_SUBST(APR_MAJOR_VERSION)
@@ -158,7 +158,7 @@ AC_ARG_WITH(libtool, [ --without-libtool avoid using libtool to link the
if test "x$use_libtool" = "xyes"; then
lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -c $< && touch $@'
- LT_VERSION="-version-info `$get_version libtool $version_hdr`"
+ LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) ${LT_VERSION} \$(ALL_LDFLAGS) -o \$@"
so_ext='lo'
lib_target='-rpath $(libdir) $$objects'