summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorgregames <gregames@13f79535-47bb-0310-9956-ffa450edef68>2001-12-04 20:37:38 +0000
committergregames <gregames@13f79535-47bb-0310-9956-ffa450edef68>2001-12-04 20:37:38 +0000
commitfeb6a1d417159f701853ee147a5d03c8dc126507 (patch)
tree222f7f784f7d2ad82734ffc7288514891802b64a /configure.in
parent40564d6dbaf749502f5a1eda64f7767509770c0c (diff)
downloadlibapr-feb6a1d417159f701853ee147a5d03c8dc126507.tar.gz
older versions of libtool don't generate the libtool script inline, so
shlibpath_var isn't a local variable to apr's configure. But this variable is set in the libtool script itself, so get it from there. OS/2, BeOS, and any platforms which don't use libtool may need to tweak this if binbuild.sh needs to work and apr[-util] is built shared. For OS/390, Jeff added a line to his libtool script that says "shlibpath_var=LIBPATH" which will do the job. also, move the AC_SUBST for shlibpath_var closer to where it is set git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@62601 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 31ca06b83..3108d9e48 100644
--- a/configure.in
+++ b/configure.in
@@ -108,6 +108,8 @@ AC_PROG_LIBTOOL
if test "x$LTFLAGS" = "x"; then
LTFLAGS='--silent'
fi
+ dnl get libtool's setting of shlibpath_var
+ eval `grep "^shlibpath_var=[[A-Z_]]\+$" $srcdir/libtool`
;;
esac
@@ -133,6 +135,7 @@ AC_SUBST(link)
AC_SUBST(so_ext)
AC_SUBST(lib_target)
AC_SUBST(export_lib_target)
+AC_SUBST(shlibpath_var)
AC_SUBST(LTFLAGS)
AC_SUBST(LT_LDFLAGS)
@@ -1368,7 +1371,6 @@ AC_SUBST(OSDIR)
AC_SUBST(DEFAULT_OSDIR)
AC_SUBST(EXEEXT)
AC_SUBST(LIBTOOL_LIBS)
-AC_SUBST(shlibpath_var)
echo "${nl}Construct Makefiles and header files."
MAKEFILE1="Makefile strings/Makefile passwd/Makefile tables/Makefile build/Makefile"