summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorstriker <striker@13f79535-47bb-0310-9956-ffa450edef68>2002-02-05 12:09:43 +0000
committerstriker <striker@13f79535-47bb-0310-9956-ffa450edef68>2002-02-05 12:09:43 +0000
commit7c06c4389be445f6a875f8f506824669b10808dd (patch)
tree0ebbba672ff764f97da47053c91d6e47fdce06d7 /configure.in
parentfcaafa25ff21ecd30cb7dda5f332a91764b98487 (diff)
downloadlibapr-7c06c4389be445f6a875f8f506824669b10808dd.tar.gz
Add a means to track where allocations are done. Show each and
every allocation with --enable-pool-debug=verbose-alloc. Know that this gives you very verbose output on stderr. Move the wrappers to the bottom of the file, since the functions are called withing apr_pools.c itself (which means <undefined> showed up as the location). git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@62916 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b94af5b2d..6eb49487a 100644
--- a/configure.in
+++ b/configure.in
@@ -189,7 +189,7 @@ AC_ARG_ENABLE(profile,[ --enable-profile Turn on profiling for the build
)dnl
AC_ARG_ENABLE(pool-debug,
- [ --enable-pool-debug[[=yes|no|verbose|lifetime|owner|all]] Turn on pools debugging],
+ [ --enable-pool-debug[[=yes|no|verbose|verbose-alloc|lifetime|owner|all]] Turn on pools debugging],
[ if test -z "$enableval"; then
APR_ADDTO(CPPFLAGS, -DAPR_POOL_DEBUG=1)
elif test ! "$enableval" = "no"; then
@@ -212,8 +212,11 @@ AC_ARG_ENABLE(pool-debug,
owner)
flag=8
;;
+ verbose-alloc)
+ flag=16
+ ;;
all)
- apr_pool_debug=15
+ apr_pool_debug=31
;;
*)
;;