summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2001-08-13 20:04:28 +0000
committertrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2001-08-13 20:04:28 +0000
commit244d61d1d63b028b5da617fc3462509fe2a86ae7 (patch)
treeedc22832fc05934193b51d5fd5eae568f6f7fc7f /configure.in
parent33a2bbdede6ad15c1e55e96e20aff963f5b25962 (diff)
downloadlibapr-244d61d1d63b028b5da617fc3462509fe2a86ae7.tar.gz
LINK shouldn't include ALL_LIBS; that puts -lm -lcrypt -lwhatever before
-o target, which some link commands can't handle; also, it left us with a lot of duplicate libraries on link invocations since our Makefiles specify the libraries to include too git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@62154 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9e79b989c..738814133 100644
--- a/configure.in
+++ b/configure.in
@@ -111,7 +111,7 @@ AC_ARG_WITH(libtool, [ --without-libtool avoid using libtool to link the
if test "x$use_libtool" = "xyes"; then
lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -c $< && touch $@'
- link='$(LIBTOOL) $(LTFLAGS) --mode=link $(LT_LDFLAGS) $(COMPILE) $(ALL_LDFLAGS) $(ALL_LIBS) -o $@'
+ link='$(LIBTOOL) $(LTFLAGS) --mode=link $(LT_LDFLAGS) $(COMPILE) $(ALL_LDFLAGS) -o $@'
so_ext='lo'
lib_target='-rpath $(libdir) $$objects'
export_lib_target='-rpath \$(libdir) \$\$objects'