summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordreid <dreid@13f79535-47bb-0310-9956-ffa450edef68>2001-07-08 02:48:53 +0000
committerdreid <dreid@13f79535-47bb-0310-9956-ffa450edef68>2001-07-08 02:48:53 +0000
commitfbed63be7720a92a06e2667f64bebd7d9c8b0193 (patch)
treecef2c3c3146cab97939afa92fa1d95cae9759509 /configure.in
parent6a2b8171e230eeb27552d903934bf5c31c72d163 (diff)
downloadlibapr-fbed63be7720a92a06e2667f64bebd7d9c8b0193.tar.gz
Add an option to configure to add -pg if we're using gcc to add profiling
information to the build. Given that we need to be concerned about performance this sort of useful addition seems like a good idea to me. Should we be leaving -O2 in the build if we're specifying -pg? git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61901 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b4cdbef98..cd0fb8a74 100644
--- a/configure.in
+++ b/configure.in
@@ -149,8 +149,14 @@ AC_ARG_ENABLE(maintainer-mode,[ --enable-maintainer-mode Turn on debugging and
])dnl
AC_ARG_ENABLE(assert-memory,[ --enable-assert-memory Turn on asserts in the APR memory code],
- [APR_ADDTO(NOTEST_CPPFLAGS,-DAPR_ASSERT_MEMORY)
-])
+ APR_ADDTO(NOTEST_CPPFLAGS,-DAPR_ASSERT_MEMORY)
+)dnl
+
+AC_ARG_ENABLE(profile,[ --enable-profile Turn on profiling for the build (GCC)],
+ if test "$GCC" = "yes"; then
+ APR_ADDTO(CFLAGS, -pg)
+ fi
+)dnl
dnl # this is the place to put specific options for platform/compiler
dnl # combinations