summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2001-07-02 16:52:27 +0000
committerjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2001-07-02 16:52:27 +0000
commitec4056ea3269c485e08a91d20641e5eccd255acd (patch)
tree0e12972524cfd98caf0015baafc1848373fd4d8f /configure.in
parente69dd2971eb6d16dd87a203f0c3cba6a2eac4391 (diff)
downloadlibapr-ec4056ea3269c485e08a91d20641e5eccd255acd.tar.gz
REALLY flip the order of the pthread_mutex_t and fcntl() decision.
I have no clue what I was thinking before. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61856 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index adeb97293..87831b62f 100644
--- a/configure.in
+++ b/configure.in
@@ -967,8 +967,8 @@ fi
# See which lock mechanisms we can support on this system.
APR_IFALLYES(func:semget func:semctl, hassysvser="1", hassysvser="0")
APR_IFALLYES(func:flock define:LOCK_EX, hasflockser="1", hasflockser="0")
-APR_IFALLYES(header:pthread.h define:PTHREAD_PROCESS_SHARED func:pthread_mutexattr_setpshared, hasprocpthreadser="1", hasprocpthreadser="0")
APR_IFALLYES(header:fcntl.h define:F_SETLK, hasfcntlser="1", hasfcntlser="0")
+APR_IFALLYES(header:pthread.h define:PTHREAD_PROCESS_SHARED func:pthread_mutexattr_setpshared, hasprocpthreadser="1", hasprocpthreadser="0")
APR_IFALLYES(struct:pthread_rw, hasrwlockser="1", hasrwlockser="0")
# See which lock mechanism we'll select by default on this system.
@@ -978,11 +978,11 @@ APR_IFALLYES(func:semget func:semctl,
APR_DECIDE(USE_SYSVSEM_SERIALIZE, [SysV IPC semget()]))
APR_IFALLYES(func:flock define:LOCK_EX,
APR_DECIDE(USE_FLOCK_SERIALIZE, [4.2BSD-style flock()]))
-APR_IFALLYES(header:fcntl.h define:F_SETLK,
- APR_DECIDE(USE_FCNTL_SERIALIZE, [SVR4-style fcntl()]))
APR_IFALLYES(header:pthread.h define:PTHREAD_PROCESS_SHARED dnl
func:pthread_mutexattr_setpshared,
APR_DECIDE(USE_PROC_PTHREAD_SERIALIZE, [pthread mutex]))
+APR_IFALLYES(header:fcntl.h define:F_SETLK,
+ APR_DECIDE(USE_FCNTL_SERIALIZE, [SVR4-style fcntl()]))
if test "x$apr_lock_method" != "x"; then
APR_DECISION_FORCE($apr_lock_method)
fi