summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorrbb <rbb@13f79535-47bb-0310-9956-ffa450edef68>2001-04-08 04:50:13 +0000
committerrbb <rbb@13f79535-47bb-0310-9956-ffa450edef68>2001-04-08 04:50:13 +0000
commitc5a334d4c17adbc1842883bc0417586c3b1d8b91 (patch)
tree272849c63b0e7ef1d6e874d72d5f0da0ef8412cf /configure.in
parent56861bdcc22acab301565d204adefa24bf9d8b1d (diff)
downloadlibapr-c5a334d4c17adbc1842883bc0417586c3b1d8b91.tar.gz
Cleanup the --without-libtool option. This ensures that the default will
always be equivalent to --with-libtool git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61476 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 7 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index b8d420df4..ed964f8b5 100644
--- a/configure.in
+++ b/configure.in
@@ -97,21 +97,20 @@ AC_PROG_LIBTOOL
esac
AC_ARG_WITH(libtool, [--with-libtool use libtool to link the library],
- [ if test "$withval" = "yes"; then
+ [ use_libtool=$withval ], [ use_libtool="yes" ] )
+
+echo "FOOBAR::::: $use_libtool"
+if test "x$use_libtool" = "xyes"; then
lt_compile="\$(LIBTOOL) --mode=compile \$(LTFLAGS) \$(COMPILE) -c \$< && touch $@"
link="\$(LIBTOOL) --mode=link \$(LTFLAGS) \$(COMPILE) \$(LDFLAGS) -o \$@ -rpath \$(libdir) \$\$objects"
so_ext="lo"
lib_target="\$(libdir) \$\$objects"
- else
+else
lt_compile="\$(COMPILE) -c \$<"
link="ar cr \$(TARGET_LIB) \$\$objects; ranlib \$(TARGET_LIB)"
so_ext="o"
- fi ], [
- lt_compile="\$(LIBTOOL) --mode=compile \$(LTFLAGS) \$(COMPILE) -c \$< && touch $@"
- link="\$(LIBTOOL) --mode=link \$(LTFLAGS) \$(COMPILE) \$(LDFLAGS) -o \$@ -rpath \$(libdir) \$\$objects"
- so_ext="lo"
- lib_target="\$(libdir) \$\$objects"
- ] )
+fi
+
AC_SUBST(lt_compile)
AC_SUBST(link)
AC_SUBST(so_ext)