summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2001-06-27 16:44:40 +0000
committertrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2001-06-27 16:44:40 +0000
commitc13508845e6778a3e7d6995930c41888f4c053d6 (patch)
treeac01f1ed5183ced718eb9c42598668c41e6cd8c2 /configure.in
parent32247ae01b42b10b30f9e1ee5d365d9eb014c2f3 (diff)
downloadlibapr-c13508845e6778a3e7d6995930c41888f4c053d6.tar.gz
clean up the generation of APR_HAS_foo_SERIALIZE just a bit by using
APR_IFALLYES() in a smarter manner git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61802 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 483513169..9ade3aa5f 100644
--- a/configure.in
+++ b/configure.in
@@ -940,14 +940,10 @@ if test "$threads" = "1"; then
fi
# See which lock mechanisms we can support on this system.
-hassysvser="0"
-hasflockser="0"
-hasfcntlser="0"
-hasprocpthreadser="0"
-APR_IFALLYES(func:semget func:semctl, hassysvser="1")
-APR_IFALLYES(func:flock define:LOCK_EX, hasflockser="1")
-APR_IFALLYES(header:fcntl.h define:F_SETLK, hasfcntlser="1")
-APR_IFALLYES(header:pthread.h define:PTHREAD_PROCESS_SHARED func:pthread_mutexattr_setpshared, hasprocpthreadser="1")
+APR_IFALLYES(func:semget func:semctl, hassysvser="1", hassysvser="0")
+APR_IFALLYES(func:flock define:LOCK_EX, hasflockser="1", hasflockser="0")
+APR_IFALLYES(header:fcntl.h define:F_SETLK, hasfcntlser="1", hasfcntlser="0")
+APR_IFALLYES(header:pthread.h define:PTHREAD_PROCESS_SHARED func:pthread_mutexattr_setpshared, hasprocpthreadser="1", hasprocpthreadser="0")
# See which lock mechanism we'll select by default on this system.
# The last APR_DECIDE to execute sets the default