summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2001-07-01 05:49:44 +0000
committerjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2001-07-01 05:49:44 +0000
commit86ea685ca4b4224590186e9e705623218a41ff3a (patch)
tree184243a8fe7fa3514b25d0520d0eb13130ac96f5 /configure.in
parent40452f7ed40bf589f64125ab0d2a438ee080ea8f (diff)
downloadlibapr-86ea685ca4b4224590186e9e705623218a41ff3a.tar.gz
Cleanup the detection of pthread_rwlock_t. Let autoconf play with
the variables and set the APR_HAS_RWLOCK_SERIALIZE in apr.h rather than in arch/unix/locks.h to be consistent with the rest of the lock types. Also, add struct to the types "known" by APR_IFALLYES. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61836 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index df0fc996b..e8d579c88 100644
--- a/configure.in
+++ b/configure.in
@@ -969,6 +969,7 @@ APR_IFALLYES(func:semget func:semctl, hassysvser="1", hassysvser="0")
APR_IFALLYES(func:flock define:LOCK_EX, hasflockser="1", hasflockser="0")
APR_IFALLYES(header:fcntl.h define:F_SETLK, hasfcntlser="1", hasfcntlser="0")
APR_IFALLYES(header:pthread.h define:PTHREAD_PROCESS_SHARED func:pthread_mutexattr_setpshared, hasprocpthreadser="1", hasprocpthreadser="0")
+APR_IFALLYES(struct:pthread_rw, hasrwlockser="1", hasrwlockser="0")
# See which lock mechanism we'll select by default on this system.
# The last APR_DECIDE to execute sets the default
@@ -1025,6 +1026,7 @@ AC_SUBST(hasflockser)
AC_SUBST(hassysvser)
AC_SUBST(hasfcntlser)
AC_SUBST(hasprocpthreadser)
+AC_SUBST(hasrwlockser)
AC_SUBST(flockser)
AC_SUBST(sysvser)
AC_SUBST(fcntlser)