summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwsanchez <wsanchez@13f79535-47bb-0310-9956-ffa450edef68>2001-04-18 17:46:39 +0000
committerwsanchez <wsanchez@13f79535-47bb-0310-9956-ffa450edef68>2001-04-18 17:46:39 +0000
commit373c183e3c0f3f31927634b2aeccb0f7985ea6e1 (patch)
tree3f08aa2bdae0518cbc0679f8df041684e144e182 /configure.in
parentf0a77f8981c86e7797710d31cc2c3d127158ef1a (diff)
downloadlibapr-373c183e3c0f3f31927634b2aeccb0f7985ea6e1.tar.gz
Check for NSLinkModule and enable dso if found.
git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61527 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c1480ce52..42e6b3f92 100644
--- a/configure.in
+++ b/configure.in
@@ -780,8 +780,11 @@ AC_ARG_ENABLE(dso,
[ --enable-dso Enable dso support ],
[ tempdso=$enableval],
[
- AC_CHECK_LIB(dl, dlopen, [ tempdso="yes" LIBS="$LIBS -ldl" ],
- tempdso="no")
+ AC_CHECK_FUNCS(NSLinkModule, [ tempdso="yes" ], [ tempdso="no" ])
+ if test "$tempdso" = "no"; then
+ AC_CHECK_LIB(dl, dlopen, [ tempdso="yes" LIBS="$LIBS -ldl" ],
+ tempdso="no")
+ fi
if test "$tempdso" = "no"; then
AC_CHECK_FUNCS(dlopen, [ tempdso="yes" ], [ tempdso="no" ])
fi