summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2001-05-31 03:30:06 +0000
committerjerenkrantz <jerenkrantz@13f79535-47bb-0310-9956-ffa450edef68>2001-05-31 03:30:06 +0000
commit30830230f2d84d25a94b32956a8aea65e54c0428 (patch)
treeaea963f3f8e176fe338ec3eeabb1f7e9f10aa94b /configure.in
parent7af6dec54f6c0f2ad7bbecdacb2a746ae34a38be (diff)
downloadlibapr-30830230f2d84d25a94b32956a8aea65e54c0428.tar.gz
Implement read write locks. This commit will support POSIX pthread
rw locks on Unix platforms. This is based on earlier patches that I posted to apr-dev, but did not receive feedback from others on. Hence, I'm committing. This will require a buildconf run for those of you who use Unix. This has only really been tested on Solaris, but it should work for those platforms that have POSIX rw locks. Other Unix platforms will simply return APR_ENOTIMPL. Add apr_lock_acquire_rw(). Notice that the Unix implementation will only allow a readwrite lock to be acquired via this function. Technically, apr_lock_acquire could obtain some sort of readwrite lock in this case, but that might lead to confusion. Added test/testlock.c which will attempt to test *both* APR_MUTEX and APR_READWRITE. This was based off of the testthread.c, but has been rewritten to use the new stdin/stdout/stderr code and just make more sense overall. testthread.c should probably be rewritten to test threading more specifically. Added framework that will hopefully still let BeOS, OS/2, and Win32 compile. Any operation relating to an APR_READWRITE lock on these platforms should just return APR_ENOTIMPL until the appropriate people get around to it. Some structure has been added to make what they have to implement fairly obvious. Again, I hope it compiles, but I can't guarantee it. Christian Gross has a Win32 readwrite lock patch floating around, but I can't vouch for Win32 code. The other platforms probably have ways to do it, but I'm not sure what they are. (Sorry, I write long commit messages...) git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@61682 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4ee64a151..3b978178e 100644
--- a/configure.in
+++ b/configure.in
@@ -280,7 +280,7 @@ else
if test "$pthreadh" = "1"; then
APR_CHECK_PTHREAD_GETSPECIFIC_TWO_ARGS
APR_CHECK_PTHREAD_ATTR_GETDETACHSTATE_ONE_ARG
- AC_CHECK_FUNCS(pthread_key_delete)
+ AC_CHECK_FUNCS(pthread_key_delete pthread_rwlock_init)
fi
fi